CES Degraded performance
Incident Report for Watermark Insights
Resolved
The recent issue affecting Course Evaluations & Surveys services has been thoroughly resolved and the case is now officially closed. After rigorous testing and monitoring, we are confident in the stability and performance of our services.

We understand the importance of continuous service availability and apologize for any inconvenience this incident may have caused. Our team has taken proactive steps to not only address the immediate issue but also to implement improvements aimed at preventing future occurrences.

Should you require further information or assistance, please reach out to our support team.

Thank you for your patience, understanding, and continued support.
Posted Sep 15, 2024 - 22:35 EDT
Update
We are continuing to monitor for any further issues.
Posted Sep 15, 2024 - 22:28 EDT
Monitoring
The issue leading to the recent service interruption affecting Course Evaluations & Surveys has been fully resolved. We are monitoring for any further disruptions.

You may resume your normal activities, and we apologize for any inconvenience this interruption may have caused.
Posted Sep 15, 2024 - 22:26 EDT
Identified
We have successfully identified the cause of the interruption affecting Course Evaluations & Surveys and are working to restore service. We will continue to provide updates as we progress towards fully resolving the issue.
Posted Sep 15, 2024 - 21:25 EDT
Investigating
We are currently investigating this issue.
Posted Sep 15, 2024 - 21:10 EDT
This incident affected: Course Evaluations & Surveys.