Between August 19 and August 20, 2026, users in System Administration experienced delays with imports and manual updates. Our team identified the concurrency bottleneck and updated the configuration to improve batch processing speed. Additional performance enhancements and monitoring are planned to prevent similar issues in the future.
Posted Aug 27, 2026 - 11:20 EDT
Resolved
The recent issue affecting Student Learning & Licensure services has been resolved and the case is now officially closed. After testing and monitoring, we are confident in the stability and performance of our services.
We understand the importance of continuous service availability and apologize for any inconvenience this incident may have caused. Our team has taken steps to address the immediate issue, and also planned additional improvements aimed at preventing future occurrences.
Should you require further information or assistance, please reach out to our support team.
Thank you for your patience, understanding, and continued support.
Posted Aug 24, 2026 - 11:18 EDT
Identified
We've identified the cause of delays with imports and manual updates in System Administration. A fix is underway to restore optimal processing speeds. We will continue to provide updates as we progress towards fully resolving the issue.
Posted Aug 21, 2026 - 15:22 EDT
Investigating
Our team is currently investigating a potential service interruption that may be affecting certain functionalities with Student Learning & Licensure. Imports and manual updates in System Administration are taking longer than usual to process, so you may experience delays with updates being reflected in Student Learning & Licensure. We apologize for the inconvenience.
Posted Aug 20, 2026 - 12:45 EDT
This incident affected: Student Learning & Licensure includes Assessment Project.