Planning & Self Study Ongoing Service Investigation

Incident Report for Watermark Insights

Postmortem

Between August 20 and August 24, 2026 users were unable to save edits to action items within the Planning & Self-Study application. The issue was introduced by a configuration change made during a routine platform update. Our team identified the misconfiguration and corrected it. The fix was tested and deployed to all production systems, restoring normal functionality. We will also be implementing additional checks to help prevent similar issues in the future.

Posted Aug 25, 2026 - 17:19 EDT

Resolved

This incident has been resolved.
Posted Aug 24, 2026 - 06:48 EDT

Identified

We have successfully identified the cause of the disruption affecting Planning and Self Study and are working to restore functionality. We will continue to provide updates as we progress towards fully resolving the issue.
Posted Aug 21, 2026 - 10:39 EDT

Investigating

Our team is currently investigating an issue where edits to an existing action item don't save, at both the outcome and measure level in Planning & Self Study.
Users will still be able to create new action items and updates.

We will continue to provide updates as we progress towards fully resolving the issue.
Posted Aug 21, 2026 - 10:21 EDT
This incident affected: Planning & Self Study.