The recent issue affecting Course Evaluations & Surveys services has been thoroughly resolved and the case is now officially closed. After rigorous testing and monitoring, we are confident in the stability and performance of our services.
We understand the importance of continuous service availability and apologize for any inconvenience this incident may have caused. Our team has taken proactive steps to not only address the immediate issue but also to implement improvements aimed at preventing future occurrences.
Should you require further information or assistance, please reach out to our support team.
Thank you for your patience, understanding, and continued support.
Posted Nov 21, 2024 - 00:53 EST
Monitoring
The issue leading to the recent service interruption affecting Course Evaluations & Surveys has been fully resolved. We are monitoring for any further disruptions.
You may resume your normal activities, and we apologize for any inconvenience this interruption may have caused.
Posted Nov 21, 2024 - 00:22 EST
Update
Our teams continue actively working on the issue affecting Course Evaluations & Surveys on the East Region. We will provide updates as we progress toward fully restoring service and/or have an estimated time to restore service.
Posted Nov 20, 2024 - 18:20 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 20, 2024 - 17:10 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 20, 2024 - 16:10 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 20, 2024 - 15:17 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 20, 2024 - 15:05 EST
Update
We continue actively working on the issue affecting Course Evaluations & Surveys on the East Region.
We will continue to provide updates as we progress toward fully restoring service. Course Evaluations & Surveys
Posted Nov 20, 2024 - 14:14 EST
Identified
We continue actively working on the issue affecting Course Evaluations & Surveys on the East Region.
We will continue to provide updates as we progress toward fully restoring service. Course Evaluations & Surveys
Posted Nov 20, 2024 - 13:07 EST
Investigating
Our team is actively working on the issue affecting Course Evaluations & Surveys on the East Coast.
We will continue to provide updates as we progress toward fully restoring service.
Posted Nov 20, 2024 - 12:06 EST
Update
We have successfully identified the cause of the interruption affecting Course Evaluations & Surveys and are working to restore service. We will continue to provide updates as we progress towards fully resolving the issue.
Posted Nov 20, 2024 - 11:00 EST
Identified
We have successfully identified the cause of the interruption affecting Course Evaluations & Surveys and are working to restore service. We will continue to provide updates as we progress towards fully resolving the issue.
Posted Nov 20, 2024 - 10:51 EST
Investigating
We have received multiple reports of issues submitting survey responses in our East region.
We will continue to provide updates as we progress towards fully resolving the issue.
Posted Nov 20, 2024 - 10:47 EST
This incident affected: Course Evaluations & Surveys.