Service disruption with Support Portal

Incident Report for Watermark Insights

Resolved

The disruption involving the Watermark Support Potal has been resolved.
We apologize for any inconvience.
Posted Feb 09, 2026 - 12:02 EST

Monitoring

A brief disruption occurred with our support portal at 9:00 AM, rendering it inaccessible.
The issue has since been resolved, and we are continuing to monitor for any further disruptions. We apologize for any inconvenience.
Posted Feb 09, 2026 - 10:27 EST
This incident affected: Course Evaluations & Surveys, Curriculum Strategy, Planning & Self Study, Student Learning & Licensure includes Assessment Project, Faculty Success, Student Success & Engagement, Outcomes Assessment Projects, Taskstream LAT, Taskstream AMS, LiveText, and Tk20.