The Watermark Student App is now fully available for download from the Apple App Store. New downloads can now be initiated and completed as expected.
Should you require further information or assistance, please reach out to our support team.
Thank you for your patience, understanding, and continued support
Posted Jul 17, 2026 - 09:27 EDT
Identified
The Watermark Student App is temporarily unavailable for download from the Apple App Store. We are actively working on a resolution to this issue. If you already have the app installed on your Apple device, it will continue to work as expected. Downloads for Android devices from the Google Play Store continue to operate as expected. As a partial workaround, users may continue to use the SS&E web UI from their mobile device. If you have urgent questions, please contact our Support Team.
Posted Jul 13, 2026 - 11:32 EDT
This incident affected: Student Success & Engagement.