Watermark Trust Center ongoing service interruption

Incident Report for Watermark Insights

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 16:06 EDT

Monitoring

Access to our Trust Center portal has been restored. We are monitoring for any further disruptions.
Posted Sep 01, 2026 - 15:28 EDT

Identified

We are currently experiencing a service disruption affecting our Trust Center portal. Watermark products and services are unaffected and operating normally. We are monitoring the situation and will provide an update once normal access is restored.
Posted Sep 01, 2026 - 13:57 EDT